Charging function not automatically shutting off

Audi A3 E-tron Forum

Help Support Audi A3 E-tron Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Aug 12, 2016
Has anyone else had this issue? Any feedback? 2017 Prestige (US spec), approx 27k miles.

Until around a week ago, when I plugged in the car in my garage at night, using the OEM charging system, in around 2.25 hours (using my 220 outlet), the vehicle would be fully charged, and the green pulsing light on the front of the car would shut off. Around a week ago, I noticed one morning that the light was still pulsing green when I went out to the car, and when opening the door, the car indicated the need for 10 minutes more of charging...although the other indicators (range, green bar pictogram) seemed to indicate a full charge (after leaving the car overnight). I was able to unplug the charger from the front of the car, give it around a minute or two, replug it in, and it would then shut off. This has continued with every charge (except one) since then. I have had to manually disconnect the charger cord to stop the pulsating green light.

I took the car to the dealer this week, and the only answer they had for me was that at temperatures above 95 degrees (F), the charger acts "weird". They said there were no codes. I live in Florida, and heat seems to be a convenient excuse, especially as the charger was fine last summer, and earlier this summer. I've been keeping the charger in my air-conditioned home since visiting the dealer this week until ready to use, and have been charging with the garage door open (hugely inconvenient) and the problem still exists. I'm considering taking it to another dealer, but wanted to ask all of you first.

While this may not be a huge issue, I'm concerned that I'm wasting a significant amount of electricity (and money) unless I manually unplug the car after around 2.25 hours. This is less than convenient if I arrive home late and choose to charge the car overnight.

Thank you!
Decided to charge the car this morning, when the garage was (and still is) relatively cool (Currently registering 83 degrees F). It's still not shutting off when charging is complete.
I thought the advertised AER was 16 miles? The Canadian model for 2016 to 2018 is 26 kms and I thought (maybe I'm wrong) that all the N.A. models had the same range.

Out of curiosity, do you have the cabin preconditioning set for a specific departure time? I've noticed that when I get to my car duing the time when I have preconditioning set, the green light will be pulsating. But to me that makes sense since the car is pulling from the grid and not using the energy in the car.

I haven't experienced the issue you have, but something along the same line.
My '16 model I've noticed a couple of times that the charging stopped the GOM only showed 20 km of range. There was still another hour of charge required but the charge duration remaining showed that there was 0 hr/min left.
Like you, I had to disconnect, reconnect and press the "charge now" button. After which, the dash showed time remaining.
I've been using a ChargePoint unit for about 2 years and this is the 1st time something like this has happened.
Past charging issues (and this was with the CP unit) I had to wiggle the chargers' handle to have it initiated charging. I tested it with the Audi unit and it charged immediately.

Hope you get a resolution to your issue.
That same issue happened to my car (2017 prem plus). The charge light light would pulse and not go out after charging was completed. I let it go over the weekend just to see if it would finish charging,
pulsed for two days. It did this on a level 1 and 2 chargers. I looked at my charge point app which shows a graph of the charge. It showed after about an hour and forty five minutes it would go into what seemed like a trickle charge mode where the added charge never went to zero but moved between .2 to .5kw of charging. This mode didn't add anything to the total charge of the battery.
Dealer couldn't find anything wrong. After about three weeks it has stopped doing this. The only difference is I seem to have lost some battery capacity. I used to always add about 6.7 to 6.8 kW of charge from empty. (Charge point app) now it never adds more than 6.3kW.
I just developed the same problem. The charger does not turn off. Was working fine till about a week ago.
Tried everything including 100% , but nothing works. Any suggestions.
The free 93M2 software update makes it so the green charge light at the plug turns off when fully charged. They used to intermittently stay on even though charging was completed.

Latest posts